Issue with merchant dashboard
Incident Report for Instamojo
Resolved
We have experienced a minor technical glitch for a short period from 4:48 pm to 4:53 pm, due to which the merchant dashboard was failing to load. This was immediately fixed and the dashboard is now working as intended.
Posted Dec 04, 2019 - 16:30 IST